Project

General

Profile

Bug #297

settle_type - gmx_fatal - constr.c

Added by servaas empty over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Small error in a gmx_fatal in constr.c:

gmx_fatal(FARGS,"More than one settle type (%d and %d)",
settle_type,ilist->iatoms[i]);

Should be his I guess:
gmx_fatal(FARGS,"More than one settle type (%d and %d)",
settle_type,ilist[F_SETTLE]->iatoms[i]);

It gives a segmentation fault, not really a problem since it should normally give a fatal error, but if you don't look at the code you don't know the cause...

History

#1 Updated by Berk Hess over 10 years ago

This was reported before on the mailing list.
I have already fixed it for 4.0.4.

Thanks anyhow,

Berk

Also available in: Atom PDF