Project

General

Profile

Bug #3023

Segmentation Fault when using pull-group1-pbcatom = -1 option

Added by Amanuel Wolde-Kidan 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
preprocessing (pdb2gmx,grompp)
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When using grompp on a system with pull-group1-pbcatom option set to -1 in the mdp file a segmentation fault is encountered. Values of pull-group1-pbcatom = 0 work. The option pull-group1-pbcatom = -1 works in gromacs 2018. A simple water box test case is attached.

test_case.zip (14.2 KB) test_case.zip Amanuel Wolde-Kidan, 07/04/2019 05:57 PM

Associated revisions

Revision 457d046b (diff)
Added by Berk Hess 4 months ago

Fix segmentation fault with cosine pulling

Both grompp and mdrun would fail with a segmentation fault when
using cosine-weighted COM pulling.

Fixes #3023

Change-Id: I6342a579251d21ba07a42d23ce578ae1e20c3286

History

#1 Updated by Kevin Boyd 5 months ago

This is caused by a pull_group_work_t->localWeights vector being empty and having an index set

#2 Updated by Paul Bauer 5 months ago

  • Status changed from New to Accepted

This got introduced during refactoring in f6157a27.
Investigating how to fix this.

#3 Updated by Paul Bauer 5 months ago

  • Status changed from Accepted to Fix uploaded

#4 Updated by Berk Hess 4 months ago

  • Status changed from Fix uploaded to Resolved

#5 Updated by Paul Bauer 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF