Project

General

Profile

Bug #3094

gmx wham doesn't compute profile.xvg with dihedral angle

Added by yujie liu 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
analysis tools
Target version:
Affected version - extra info:
all version
Affected version:
Difficulty:
uncategorized
Close

Description

As previous mentioned https://redmine.gromacs.org/issues/2903 . I also found this bug in gromacs 2019.3, when I calculate the PMF of dihedral angle rotation. I pose a question on maillist
https://mailman-1.sys.kth.se/pipermail/gromacs.org_gmx-users/2019-September/126614.html

4.jpg (23.3 KB) 4.jpg source code yujie liu, 09/28/2019 12:38 AM
5.jpg (25.1 KB) 5.jpg The result yujie liu, 09/28/2019 12:38 AM

Associated revisions

Revision 592be1a9 (diff)
Added by Berk Hess 2 months ago

Actually fix gmx wham with angle geometries

A previous fix for converting the force constant in gmx wham
for angle and dihedral geometry applied an incorrect conversion
factor.

Fixes #2609 and #3094

Change-Id: I0aa9b848c7fa62306ccf15b327a650b1ad88e03f

History

#1 Updated by Paul Bauer 2 months ago

I started debugging this, and it looks like the issue is that the calculated force constant is too high, leading to the result of an exponential function being nan

#2 Updated by Berk Hess 2 months ago

Could this be a radian/degree unit issue?

#3 Updated by yujie liu 2 months ago

Berk Hess wrote:

Could this be a radian/degree unit issue?

I think it is. If I change the source code of g_wham.cpp by add a conversion factors ((pi/180)²), the result may be fine. But only use to calculate PMF of angle. Please see attachment.

#4 Updated by Paul Bauer 2 months ago

#5 Updated by yujie liu 2 months ago

Paul Bauer wrote:

please try the fix here: https://gerrit.gromacs.org/c/gromacs/+/13477

Yes, it is correct.

#6 Updated by Paul Bauer 2 months ago

  • Status changed from New to Resolved

#7 Updated by Paul Bauer 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF