Project

General

Profile

Bug #31

lipid membrane simulation crashed using 3 fs time step with 3.3

Added by Qing Zhu about 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I tried to run a 'popc + cholesterol" membrane simulation using 3 fs as the time
step with gromacs-3.3, but my simulation always crashed after a short time
unless I changed the time step back to 2 fs. And the only message I could get
from crashed simuations is
"One of the processes started by mpirun has exited with a nonzero exit code.
This typically indicates that the process finished in error.
If your process did not finish in error, be sure to include a "return
0" or "exit(0)" in your C code before exiting the application."

But if I used the same initial conditions (same starting structure, md.mdp, popc
and cholesterol topology, and so on) to run the simulation with gromacs-3.2.1,
there was no problem, and I even could use 4 fs as the time step with
gromacs-3.2.1.

I used gmxcheck to compare the 3.2.1 tpr and 3.3 tpr, and I got hundreds of
pages of difference, which I don't understand because all the initial conditions
are the same expcept the gromaces version. I also tried to run the 3.2.1 tpr
with gromacs-3.3, and simulation still crashed after several thunsand steps.

I will upload 3.2.1 tpr and 3.3 tpr, so what I did could be reproduced.

md-3.2.1.tpr (5.06 MB) md-3.2.1.tpr 3.2.1 tpr file for 1.8 ns of popc + cholesterol membrane using 3 fs time step Qing Zhu, 11/10/2005 12:14 AM
md-3.3.tpr (5.18 MB) md-3.3.tpr 3.3 tpr file for 1.8 ns of popc + cholesterol membrane using 3 fs time step Qing Zhu, 11/10/2005 12:16 AM
topol.tpr (7.63 MB) topol.tpr 3.2.1 run input that crashes with 3.3 mdrun (but not 3.2.1) Alan Dodd, 02/22/2006 03:24 PM

History

#1 Updated by Qing Zhu about 14 years ago

Created an attachment (id=7)
3.2.1 tpr file for 1.8 ns of popc + cholesterol membrane using 3 fs time step

#2 Updated by Qing Zhu about 14 years ago

Created an attachment (id=8)
3.3 tpr file for 1.8 ns of popc + cholesterol membrane using 3 fs time step

#3 Updated by Alan Dodd over 13 years ago

Created an attachment (id=17)
3.2.1 run input that crashes with 3.3 mdrun (but not 3.2.1)

Another lipid simulation that crashes within a couple thousand steps, but only
with version 3.3. 3.3 .tpr files tend to crash quicker with this structure
(not included) but gmxcheck between the two, flags only:

comparing inputrec
inputrec->sc_power (2 - 1)
inputrec->dihre_fc (1.401298e-42 - 1.000000e+03)

Varying the number of nodes strongly affects the time taken for the simulation
to crash. And reducing the timestep, of course, prevents crashes or any LINCS
errors.
Thought a different system might help track down the source of the problem.

#4 Updated by David van der Spoel over 13 years ago

The problem reported by Alan Dodd is probably due to an issue in PME that was
fixed after the release of 3.3 and which prevented use of a pme_order different
than 4 (in the 3.2.1 input file from Alan Dodd 8 is used). Strangly this 3.2.1
tpr file uses a timestep of 1.5 fs only. You can download a modified pme.c file
from the ftp site. This problem may be unrelated to the original one. Your tpr
file ran fine on my 16 way box with a fully patched 3.3 installed.

(Mnbf/s)   (GFlops)   (ns/day)  (hour/ns)
Performance: 95.529 19.555 1.592 15.074

#5 Updated by David van der Spoel over 13 years ago

Will now test the other tpr file

#6 Updated by David van der Spoel over 13 years ago

Qing Zhu,

I tried to reproduce your problem. It has not crashed for me after 5000 steps
but I think it will because you are using bonds instead of constraints even for
the water. This is not a good idea. The temperature of the water is 600 K in
your simulations and fluctuating wildly. You should remove the -DFLEXIBLE in the
mdp file and set constraint = all-bonds

Therfore this is not a bug.

Also available in: Atom PDF