Project

General

Profile

Bug #3107

editconf not updating atom names correctly

Added by Dallas Warren 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
simple
Close

Description

If you select a subset of atoms using editconf, atom names are not correctly propagated into the output coordinate file. It appears that it simply copies directly over from the input file in the same numerical order i.e. source file is C1 C2 C3 C4 .... and the filtered file is expected to be C10 C11 C12 C13 ... but it is still labelled as C1 C2 C3 C4.... And it makes no difference what the selected group is, how it is selected, whether from the default groups generated without an index file, or if the groups are from an index file, the atom names are not propagated correctly in any permutation I have tried. All other information such as atom number and coordinates are transferred correctly, it is the atom name that is not updated correctly.

Works correctly with 2016.3

Associated revisions

Revision 6c1b268a (diff)
Added by Mark Abraham 2 months ago

Fix gro file output with index groups

The bug was found with editconf, but the issue was present in writing
of any gro file for which index groups were used (not just index
groups supplied by the user).

Fixes #3107

Change-Id: I3fc586c69066a354b3210d9616125ef666f1ce26

Revision e91fa76b (diff)
Added by Mark Abraham 2 months ago

Add tests for editconf file conversion with indexing

The indexed output to gro files illustrates bug #3107

Fixed two memory leaks necessary to let the tests pass

Refs #3107

Change-Id: Ie61430210ac8a804fb86783c8b76c41333b8d3cf

Revision bc406d20 (diff)
Added by Mark Abraham 2 months ago

Fix gro file output with index groups

Fixes #3107

Change-Id: I3fc586c69066a354b3210d9616125ef666f1ce26

History

#1 Updated by Mark Abraham 3 months ago

  • Status changed from New to Accepted
  • Assignee set to Mark Abraham
  • Target version set to 2019.4

Thanks for the report. I have reproduced and am bisecting to see when the problem was introduced, so we can fix it.

#2 Updated by Mark Abraham 3 months ago

My 40f1c8eaa2bfa37f7c28d55262d3af7daac1b967 seems to have made the problem

#3 Updated by Mark Abraham 3 months ago

The fix is simple, but unfortunately applies to all indexed gro-file output. I'll add it for the 2019.4 fixes shortly.

#4 Updated by Mark Abraham 2 months ago

  • Status changed from Accepted to Fix uploaded

Tests on master branch at https://gerrit.gromacs.org/c/gromacs/+/13403/2, fix at https://gerrit.gromacs.org/c/gromacs/+/13404/1. Will make a patch with just the fix for release-2019, once we're happy with master.

#5 Updated by Mark Abraham 2 months ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Mark Abraham 2 months ago

#7 Updated by Paul Bauer 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF