Project

General

Profile

Bug #318

rerun produces inconsistent values for (shifted) virial when external force is used

Added by Alexander Herz over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The attached tpr files along with script run a system with low density walls
(small effect on the system) and then rerun the same trajectory on the same input data. Then the virial xx/yy/zz components on both runs' edr files is computed using g_energy giving different virial values (which is clearly wrong as far as I can tell).

Using an external force like e-field, walls or similar force in z only causes weird deviations in the (shifted) virial (see attached log files), all other virial contributions converge to sensible (and very similar) values. The shifted virial contribution also seems to be responsible for the inconsistent rerun values.

walls.tar.gz (92.8 KB) walls.tar.gz tpr input files and averaged virial logs Alexander Herz, 04/27/2009 02:39 PM

Related issues

Is duplicate of GROMACS - Bug #317: mdrun -rerun works incorrectly for multiple processors and domain decompositionClosed04/24/2009

History

#1 Updated by Alexander Herz over 10 years ago

Created an attachment (id=365)
tpr input files and averaged virial logs

#2 Updated by Berk Hess over 10 years ago

You have only attached one tpr file.
With that one I get consistent values between running it and rerunning it.

Berk

#3 Updated by Berk Hess over 10 years ago

I have found that the difference is caused by the constraint
contribution to the virial.
When you set the env var GMX_CONSTRAINTVIR you will get the force
and the constraint contributions to the virial in the energy file.
The force parts match for original and rerun, whereas the constraint
part is zero for rerun.
I'll have to figure out what goes wrong there.
But I think the everything (potential, forces, etc) is correct,
except for the (constraint) virial output of the rerun.

Berk

#4 Updated by Berk Hess over 10 years ago

With rerun the constraint virial is not zero but slightly different,
at least at step 0.
I will need more time to look deeper into this.
It will probably have to wait till next week.

But as I said, it seems the force virial is fine.

Berk

#5 Updated by Alexander Herz over 10 years ago

Great to hear you're making progress here.
As soon the rerun works I can investigate more where my problem is actually coming from.

#6 Updated by Berk Hess over 10 years ago

I was trying to say that I think rerun works fine,
except for the constraint virial and the total pressure.
But if you want to be 100% sure, you'll have to wait a few days.

Berk

#7 Updated by Berk Hess over 10 years ago

I have fixed (I think) all the issues.
At the same time I fixed bugzilla 317.
But my fix has nothing (directly) to do with walls.
Could you check that your problems are resolved now?

The fix is both in the 4.0 release and in the head branch.

Berk

#8 Updated by Berk Hess over 10 years ago

Can we already close this bug?

Berk

#9 Updated by Berk Hess over 10 years ago

This cause of the issue was also responsible for other incorrect
results reported in bugzilla 317.
It has been fixed for 4.0.5 and 4.1

Berk

Also available in: Atom PDF