Project

General

Profile

Bug #35

trjconv does not read velocities from g96 file.

Added by Ramon Garcia almost 14 years ago. Updated almost 14 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When using trjconv to convert a .g96 file to a .trr file, the output file does
not contain velocities.

The cause of this problem is a typo in the source src/tools/gmx_trjconv.c

The source reads (line 700 in Gromacs 3.3):

bVels= (ftp==efTRR || ftp==efTRJ || ftp==efGRO || ftp==efG96) 
&& (ftpin==efTRR || ftpin==efTRJ || ftpin==efGRO || ftp==efG96);

Note the mistake at the end of the second line. The source should read:

bVels= (ftp==efTRR || ftp==efTRJ || ftp==efGRO || ftp==efG96) 
&& (ftpin==efTRR || ftpin==efTRJ || ftpin==efGRO || ftpin==efG96);

History

#1 Updated by Erik Lindahl almost 14 years ago

Fixed in both branches of CVS.

Also available in: Atom PDF