Project

General

Profile

Bug #36

two errors concerning trjconv -b -e

Added by Juergen Haas almost 14 years ago. Updated almost 14 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

several failures on the same xtc file(do not occur with 3.2.1):
(This might be related to Bug #15...)

**on calling trjconv(3.3) on a xtc file of length 75464.4:
trjconv -b 74464 -e 74464 - f example.xtc
-o /storage3/test.xtc -s example.tpr

Selected 0: 'System'
Reading frame 0 time 43140.004
-------------------------------------------------------
Program trjconv, VERSION 3.3
Source code file: xtcio.c, line: 232
Fatal error:
Frame contains more atoms (1450669029) than expected (24191)
-------------------------------------------------------

**If I choose b to be 74460:
Reading frame 0 time 43140.004
------------------------------------------------------

Program trjconv, VERSION 3.3
Source code file: xtcio.c, line: 83
Fatal error:
Magic Number Error in XTC file (read -1099941949, should be 1995)

I unfortunately do not seem to be able to make a small sample traj which fails.
(
one from 43000 to 47000(still 1.5 Gb), only gives the following error:
WARNING no output, trajectory ended at 4456000
)

**Values below 40000 seem to work just fine

**If I choose one of the following b (same as -e) [56][01]000:
Reading frame 0 time 43140.004
------------------------------------------------------

Program trjconv, VERSION 3.3
Source code file: trxio.c, line: 631

Fatal error:
Specified frame doesn't exist or file not seekable
-------------------------------------------------------

**If I choose -b (also -e) 457000:
Last frame -1 time 43140.004
Using output precision of 0.001 (nm)

WARNING no output, trajectory ended at 47000


Related issues

Is duplicate of GROMACS - Bug #15: trjconv skipping frame errorClosed09/22/2005

History

#1 Updated by Erik Lindahl almost 14 years ago

Hi Juergen,

This is possibly a duplicate of another bug in the XTC searching code. Just to make sure, could you
check that the xtc file is OK e.g. by "trjconv -s example.tpr -f example.xtc -o scratch.xtc"

(i.e., no random access/begin/end options).

If that's the case I'll mark this one as a duplicate and ask you to upload the tpr/xtc files as an
attachment to the other bug (we've had some problems replicating it).

Cheers,

Erik

#2 Updated by Erik Lindahl almost 14 years ago

  • This bug has been marked as a duplicate of 15 ***

Also available in: Atom PDF