Project

General

Profile

Bug #37

Implicit water constraints silently break conjugate gradient mimization

Added by Mark Abraham almost 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

There was some discussion on gmx-users of systems solvated in water that users
were trying to use CG energy mimization on. They ran into problems with grompp
such as
"processing coordinates...
double-checking input for internal consistency...
ERROR: can not do Conjugate Gradients with constraints (201522)"
which was thought to be caused by the implicit constraints in the rigid water
model, since the user had specified no constraints in the .mdp file. One user
reported that adding "-DFLEXIBLE" to their .mdp file allowed CG EM to run.

See discussion at
http://www.gromacs.org/pipermail/gmx-users/2005-December/018714.html and
http://www.gromacs.org/pipermail/gmx-users/2005-December/018750.html

David Mobley and I thought that explicit discussion of this in the manual should
be considered -
1) in the CG section, a note that rigid water models won't work because of the
explicit constraints, and the need to overcome this with -DFLEXIBLE, if suitable
2) a mention of water constraints in the constraints section(s)
3) a more descriptive error message when using grompp to set up CG with EM if
the constraints are only associated with a rigid solvent

Any of the above will help a user recognise the problem.

History

#1 Updated by David van der Spoel over 13 years ago

I don't understand point two below, but have updated both the error message in
grompp and the manual.

#2 Updated by Mark Abraham over 13 years ago

(In reply to comment #1)

I don't understand point two below, but have updated both the error message in
grompp and the manual.

Of course... I was confusing the GROMACS usage of "restraints" and "constraints"
in my mind.

Also available in: Atom PDF