Project

General

Profile

Bug #40

freeze groups on protein causes log file runaway during equilibration with constant pressure, even with weak coupling

Added by David Mobley almost 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I have a protein-ligand system in explicit solvent, and I'm trying to hold the
protein fixed using freeze groups. During constant pressure equilibration, I get
log file runaway. The log file fills (up to several GB until I kill the job)
with comments like these:

Correcting invalid box:
old box (3x3):
old box[ 0]={-9.99426e+21, 0.00000e+00, -0.00000e+00}
old box[ 1]={ 0.00000e+00, -9.99426e+21, -0.00000e+00}
old box[ 2]={-4.99713e+21, 3.07191e+28, -7.06701e+21}
new box (3x3):
new box[ 0]={-9.99426e+21, 0.00000e+00, -0.00000e+00}
new box[ 1]={ 0.00000e+00, -9.99426e+21, -0.00000e+00}
new box[ 2]={-4.99713e+21, 3.07191e+28, -7.06701e+21}

According to the manual, freeze groups should work OK even with pressure
coupling (I'm using Berendsen) but that seems not to be the case here. I can,
however, run the same system using position restraints rather than freeze groups
-- but I'd rather use freeze groups.

I've tried weaker pressure coupling (tau_p=2.0) per David's suggestion, but as
far as I can tell this makes no difference.

I'll submit topology, .gro, and tpr files to reproduce this.

bugzilla.tar.gz (1.36 MB) bugzilla.tar.gz Tarball to reproduce the problem David Mobley, 01/04/2006 08:53 PM
ions.itp (4.01 KB) ions.itp ions.itp David Mobley, 03/02/2006 06:27 PM
ions.itp (4.26 KB) ions.itp correct ions.itp David Mobley, 03/02/2006 09:04 PM

History

#1 Updated by David Mobley almost 14 years ago

Created an attachment (id=10)
Tarball to reproduce the problem

.top, .gro, .mdp and .tpr files for the run in question.

#2 Updated by David van der Spoel over 13 years ago

I have fixed the easy bit: the infinite writing to a log file (had a 200Gb
md.log file myself last week). But for the freeze problem you will have to
supply the amber files, in particular the ions.itp or similar.

#3 Updated by David Mobley over 13 years ago

Created an attachment (id=21)
ions.itp

Here's the ions.itp file. If you should need other include files for AMBER they
are all available from the Amber port website
http://folding.stanford.edu/ffamber/. This is the one that I had modified by
hand.

Let me know if you need anything else. Thanks.

#4 Updated by David Mobley over 13 years ago

Created an attachment (id=23)
correct ions.itp

Correct ions.itp

#5 Updated by David van der Spoel over 13 years ago

There is a problem in the input that is not easy to work around. You have
defined constraints and freeze groups on the same atoms, and use pressure
scaling. The problem is that in a periodic systems there is no absolute
reference for coordinates. Berk suggested we perform center of mass displacement
of the frozen atoms in response to fluctuations. There really are two option:
- Forbidding this combination (e.g. pressure coupling with freezing). Good to
prevent novice user from doing something wrong, bad to hinder users who know
what they're doing.
- Implement some kind of fix including turning off the constraints between pairs
of frozen atoms

Either way we'll not do it right away, but we can keep the discussion going.

#6 Updated by David Mobley over 13 years ago

David,

That's fine by me. Actually, it is adequate for my purposes to know that freeze groups and constraints
don't work at the same time. Maybe this could be documented? The manual (at least the 3.2 manual)
does say that freeze groups works with pressure coupling (which seems to be an accomplishment in
itself, as I imagine this is a bit difficult!), so I was puzzled as to why it wasn't working for me. Just
putting a comment in the manual where it says freeze groups works with pressure coupling addding
"(but not with constraints on the same atoms)" would solve it as far as I'm concerned.

Thanks,
David

#7 Updated by David van der Spoel over 13 years ago

Updated the manual to reflect the real situation and to warn for this problem.

Also available in: Atom PDF