Project

General

Profile

Bug #44

genbox or NS does not return allocated memory

Added by Erik Lindahl almost 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When inserting ~1000 small molecules with genbox -ci, the program uses increasingly more memory until
it crashes with an out-of-memory error.

The system size is only about 10k atoms, so the neighborlists shouldn't be particularly large.

History

#1 Updated by David van der Spoel over 13 years ago

The problem is that the neighborlist is reallocated at each step, I've tried to
find why and also to free the memory but without success. Maybe it's good to
wait with fixing this until 4.0.

Of course a workaround is to run genbox a couple of times.

#2 Updated by David van der Spoel over 13 years ago

When we do the proper modularization of the neighborsearching we can fix this.
Right now there to many low-level routines being called out of the proper context.

Also available in: Atom PDF