Project

General

Profile

Bug #48

Gromacs compilation error with lam/mpi

Added by no name almost 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Low
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Gromacs-3.3 does not compile with lam/mpi-7.1.1 on EM64T platform with
kernel.org kernel 2.6.9-5.ELsmp. The configure script fails with the following
error:

checking size of int... configure: error: cannot compute sizeof (int), 77

It is quite critical for me as I am not able to proceed further.

History

#1 Updated by David van der Spoel over 13 years ago

Please send the complete output from the configure step (config.log)

Did you compile FFTW yourself?

#2 Updated by Stéphane Téletchéa over 13 years ago

On similar system, i've been able to compile gromacs 3.3 flawlessly :

LAM/MPI 7.1.1
Intel EMT64 3.2 GHz xeons
Mandriva linux 2005
gcc version 3.4.3 (Mandrakelinux 10.2 3.4.3-7mdk)

I used the bundled fftw or my own version and all worked.

Compilation options :
./configure --prefix=$DESTDIR/gromacs-$VER --enable-sse2 --enable-fortran
--with-gnu-ld --enable-double

I can provide more input if needed.

#3 Updated by David van der Spoel over 13 years ago

Please turn off fortran. It is useless on Pentiums because of the assembly loops.

#4 Updated by David van der Spoel over 13 years ago

I tried to reproduce the problem using all the flags to configure that you have
specified, but no success i.e. it works fine). Try dropping the fortran, sse2
and gnu-ld flags.

Also available in: Atom PDF