Project

General

Profile

Bug #544

-chainsep

Added by nahren empty about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Dear Gromacs Users,

Justin, I took your advice and using 4.5.1.

I have attached the PDB file for your consideration.
http://www.4shared.com/file/RwF_wuja/chainABCRST.html

Command : newpdb2gmx -f chainABCRST.pdb -p dimertop.top -o dimerpdb.pdb -chainsep interactive -ignh

8: CHARMM27 all-atom force field (with CMAP) - version 2.0beta (forcefield selected)

6: None (water model)

Reading chainABCRST.pdb...
Read 6636 atoms
Analyzing pdb file
Splitting PDB chains based on TER records or changing chain id.
Merge chain ending with residue LEU144 (chain id 'A', atom 1444 OXT) with
chain starting with residue LYS284 (chain id 'B', atom 1445 N)? [n/y]
y
Merge chain ending with residue LEU427 (chain id 'B', atom 2888 OXT) with
chain starting with residue LYS567 (chain id 'C', atom 2889 N)? [n/y]
y
Merge chain ending with residue LEU710 (chain id 'C', atom 4332 OXT) with
chain starting with residue CYS145 (chain id 'R', atom 1 N)? [n/y]
n
Merge chain ending with residue CYS283 (chain id 'R', atom 1400 OXT) with
chain starting with residue CYS428 (chain id 'S', atom 1401 N)? [n/y]
y
Merge chain ending with residue CYS566 (chain id 'S', atom 2800 OXT) with
chain starting with residue CYS711 (chain id 'T', atom 2801 N)? [n/y]
y

Program newpdb2gmx, VERSION 4.5.1
Source code file: pdb2gmx.c, line: 655

Fatal error:
Atom OXT in residue LEU 427 was not found in rtp entry LEU with 19 atoms
while sorting atoms.

***
But this selection works (for the same above command, 1 )

Merge chain ending with residue LEU144 (chain id 'A', atom 1444 OXT) with
chain starting with residue LYS284 (chain id 'B', atom 1445 N)? [n/y]
y
Merge chain ending with residue LEU427 (chain id 'B', atom 2888 OXT) with
chain starting with residue LYS567 (chain id 'C', atom 2889 N)? [n/y]
n
Merge chain ending with residue LEU710 (chain id 'C', atom 4332 OXT) with
chain starting with residue CYS145 (chain id 'R', atom 1 N)? [n/y]
y
Merge chain ending with residue CYS283 (chain id 'R', atom 1400 OXT) with
chain starting with residue CYS428 (chain id 'S', atom 1401 N)? [n/y]
n
Merge chain ending with residue CYS566 (chain id 'S', atom 2800 OXT) with
chain starting with residue CYS711 (chain id 'T', atom 2801 N)? [n/y]
y


After ABC , I include a 'TER', then start chain RST, and make 'chainsep ter'

2. newpdb2gmx -f chainABCRSTter.pdb -p dimertop.top -o dimerpdb.pdb -chainsep ter -ignh
Program newpdb2gmx, VERSION 4.5.1
Source code file: pdb2gmx.c, line: 655

Fatal error:
Atom OXT in residue LEU 427 was not found in rtp entry LEU with 19 atoms
while sorting atoms.

The residue are not in sequential Order , but i dont think that is the problem here.

Thank you.

Best,
nahren

History

#1 Updated by Berk Hess about 9 years ago

The problem is that LEU 427 explicitly has two oxygens (O1 and O2)
in the pdb file. If you want to merge the chains it should have only one oxygen.
You should remove O2 by hand (pdb2gmx renames it to OXT).

Berk

#2 Updated by Berk Hess about 9 years ago

I realized now that what you probably want is to have several protein molecules,
each with a pair of termini, in a single molecule_type defintion,
to be able to have cys-bonds between them.

It seems that pdb2gmx does not do what it should do, because it only picks
up the very first and very last residue of the set of chains as terminal.
Erik should look into this.

Berk

#3 Updated by nahren empty about 9 years ago

(In reply to comment #2)

I realized now that what you probably want is to have several protein
molecules,
each with a pair of termini, in a single molecule_type defintion,
to be able to have cys-bonds between them.

It seems that pdb2gmx does not do what it should do, because it only picks
up the very first and very last residue of the set of chains as terminal.
Erik should look into this.

Berk

In the previous version, the pdb2gmx -merge works fine. Also with the pdb2gmx -chainsep, I am able to merge two chains only.

I was actually looking to apply distance constraints between a domain in each of the hexamers.

nahren

#4 Updated by Berk Hess almost 9 years ago

I fixed it for the upcoming 4.5.2 release.
The fix it the following commit in the release-4-5-patches branch:
9e15271b8c82b782f181f8b78979a096ba8012d6

Berk

Also available in: Atom PDF