Project

General

Profile

Bug #56

Pull code and Index group problem

Added by Andrea Carotti over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Trying to make an AFM simulation, in which I want to make interact two small
proteins (42 aa, identical, called p1 and p2).p1 is the pulled group and the p2
is the reference group. The md run has the LINCS constraints on all
bonds,explicit solvent (spc) with gromos ff official distro. The system is well
minimized and equilibrated. The index file contains all the typical groups
(system...) and the two ones (name p1 corresponding to residues 1-42 and p2
res.43-84)i need. The md.c used for the compilation is been downloaded from the
bugzilla page http://bugzilla.gromacs.org/show_bug.cgi?id=26.
After the commands:

grompp -f PME_NPT_fullMD.mdp -c Pull.gro -p Pull.top -o Pull.tpr -v
mdrun -s Pull.tpr -o Pull_fullMD.trr -c Pull_fullMD.gro -e Pull_fullMD.edr -pi

pull.ppa -pn pull.ndx -v

I receive this error message:
Program mdrun, VERSION 3.3
Source code file: pullinit.c, line: 215
Fatal error:
in the index file1
Halting program mdrun

I've created a zip file containing all the necessary files (Pull.gro,
PME_NPT_fullMD.mdp, pull.ppa, Pull.top, Pull.ndx) for the reproducibility.
Also the verbose = yes is not working (it remains set to no).
It would be nice to have this fixed as soon as possible, as we can't proceed on
our project until it is working.

Thanks for your help.

pull.zip (753 KB) pull.zip Files for the reproducibility Andrea Carotti, 03/23/2006 10:23 AM
Missing_itp.zip (29.7 KB) Missing_itp.zip Missing needed topologies files (.itp) Andrea Carotti, 03/23/2006 11:17 AM

History

#1 Updated by Andrea Carotti over 13 years ago

Created an attachment (id=28)
Files for the reproducibility

#2 Updated by Andrea Carotti over 13 years ago

Created an attachment (id=29)
Missing needed topologies files (.itp)

These files called Pull_A.itp and Pull_B.itp contain the topologies of the two
proteins (p1 and p2).

#3 Updated by Berk Hess over 13 years ago

The problem is that your pull.ppa file (as well as your mdp
file which did not work for me) is in DOS format.
Thus each line ends in a carriage return + line feed,
instead of only line feed as in UNIX.

When working in UNIX you should use proper UNIX ascii files.
These problems often occur when ftp'ing ascii files
where a DOS machine is involved, in that case you need to
set type to bin.

Berk.

#4 Updated by Andrea Carotti over 13 years ago

Sorry for this stupid mistake...
Thanks a lot however for you kind help
Best regards
Andrea

Also available in: Atom PDF