Project

General

Profile

Bug #61

dihedral restraint force constant not converted from degrees

Added by David Mobley over 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
High
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The function of the dihedral restraints is currently a bit odd, and probably should be considered a bug:
phi 0 and dphi are read from the topology file in degrees and converted internally to radians, but the
force constant (kfac) is used as read. In other words, to get the expected behavior, one would need to
specify phi and dphi in the topology file in units of degrees, but the force constant in units of kJ/rad^2
(rather than the expected kJ/degree^2).

Probably this should be fixed so that expected input units are consistent. The relevant lines are in
dihres.c:

phi0  = ip[type].dihres.phi*d2r;
dphi = ip[type].dihres.dphi*d2r;
kfac = ip[type].dihres.kfac*fc;

Sorry, I should have caught this before. I finally figured it out because I realized I was using units of kJ/
rad^2 for my input force constants but the input angles were in degrees. I had adjusted the force
constant to get the restraint energy I was expecting, so I didn't notice before.

History

#1 Updated by David van der Spoel over 13 years ago

This is by design, and is the same for all other angle and dihedral forces.
Hence it is not a bug. I agree that it is not very elegant, it would be very
messy to change it however, because it would imply reading interpreting the
force constants in another way. I added a small remark in the manual in the
relevant sections.

#2 Updated by David Mobley over 13 years ago

OK, great. I realized after I submitted it that the angle force constant has the same units, so I can see why
it is a bit confusing. Fixing the documentation should solve the problem, since essentially the problem
was just that the 3.2 manual doesn't even mention dihedral restraints, so it's not clear what units one
should expect things to be in.

#3 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=218)
avodart

#4 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=219)
buspar

#5 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=220)
cephalexin

#6 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=221)
epivir

#7 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=222)
levitra

#8 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=223)
lisinopril

#9 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=224)
metronidazole

#10 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=225)
plavix

#11 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=226)
seroquel

#12 Updated by Ruby Lutz over 12 years ago

Created an attachment (id=227)
ziac

#13 Updated by Erik Lindahl over 12 years ago

The content of attachment 227 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:14:49 CET.

#14 Updated by Erik Lindahl over 12 years ago

The content of attachment 226 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:15:11 CET.

#15 Updated by Erik Lindahl over 12 years ago

The content of attachment 218 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:21:52 CET.

#16 Updated by Erik Lindahl over 12 years ago

The content of attachment 223 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:22:20 CET.

#17 Updated by Erik Lindahl over 12 years ago

The content of attachment 219 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:22:42 CET.

#18 Updated by Erik Lindahl over 12 years ago

The content of attachment 220 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:23:00 CET.

#19 Updated by Erik Lindahl over 12 years ago

The content of attachment 221 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:24:09 CET.

#20 Updated by Erik Lindahl over 12 years ago

The content of attachment 222 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:24:25 CET.

#21 Updated by Erik Lindahl over 12 years ago

The content of attachment 224 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:24:42 CET.

#22 Updated by Erik Lindahl over 12 years ago

The content of attachment 225 has been deleted by
Erik Lindahl <>
who provided the following reason:

spam

The token used to delete this attachment was generated at 2007-08-15 21:25:15 CET.

Also available in: Atom PDF