Project

General

Profile

Bug #64

pdb2gmx assigns non-existant atom (H211) when processing RNA

Added by Ken Rotondi over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

OVERVIEW:
I have added hydrogen data base entries for the RNA nucleotides to the ffG53a5.hdb file (appended).
When processing a large RNA chain, pdb2gmx (pdb2gmx f test.pdb -v -ignh) returned the following
fatal error:
------------------------------------------------------

Program pdb2gmx, VERSION 3.3
Source code file: add_par.c, line: 221

Fatal error:
Atom H211 not found in rtp database in residue GUA, it looks a bit like H21
-------------------------------------------------------
I reduced the .pdb file to the first nucleotide (a GUA, coordinates appended) and pdb2gmx returned the
same error.

STEPS TO REPRODUCE:
add the RNA entries (at end of description) to ffG53a5.hdb
run pdb2gmx -f test.pdb (coordinates at end of description) -ignh

ACTUAL RESULTS:
pdb2gmx fails stating that ATOM H211 is not found. There is no occurrence of an ATOM H211 in either
the pdb or hdb files.

EXPECTED RESULT:
.gro and .top files for the nucleotide

BUILD & PLATFORM:
GROMACS 3.3 Linux (fedora core 3, latest patches) Intel P4 2.26 GHz

ADDITIONAL INFORMATION:
hydrogen database entries for RNA nucleotides
ADE 3
1 2 H2* O2* C2* C3*
2 3 H61 N6 C6 N1
2 3 H62 N6 C6 N1
GUA 4
1 2 H2* O2* C2* C3*
2 3 H21 N2 C2 N1
2 3 H22 N2 C2 N1
1 1 H1 N1 C6 C2
CYT 3
1 2 H2* O2* C2* C3*
2 3 H41 N4 C4 N3
2 3 H42 N4 C4 N3
URA 2
1 2 H2* O2* C2* C3*
1 1 H3 N3 C2 C4

coordinates for test.pdb
ATOM 1 P GUA A 1 4.006 48.703 126.810 1.00 58.91
ATOM 2 O2P GUA A 1 4.598 50.201 126.810 1.00 58.91
ATOM 3 O1P GUA A 1 3.130 48.474 125.479 1.00 58.91
ATOM 4 O5* GUA A 1 5.220 47.646 126.843 1.00 58.91
ATOM 5 C5* GUA A 1 6.464 48.349 126.894 1.00 58.91
ATOM 6 C4* GUA A 1 7.236 48.051 128.158 1.00 58.91
ATOM 7 O4* GUA A 1 7.567 46.637 128.194 1.00 58.91
ATOM 8 C1* GUA A 1 8.854 46.462 128.764 1.00 58.91
ATOM 9 N9 GUA A 1 9.716 45.855 127.755 1.00 58.91
ATOM 10 C4 GUA A 1 10.914 45.215 127.975 1.00 58.91
ATOM 11 N3 GUA A 1 11.509 45.032 129.173 1.00 58.91
ATOM 12 C2 GUA A 1 12.655 44.380 129.062 1.00 58.91
ATOM 13 N2 GUA A 1 13.383 44.113 130.156 1.00 58.91
ATOM 14 N1 GUA A 1 13.174 43.942 127.869 1.00 58.91
ATOM 15 C6 GUA A 1 12.580 44.119 126.624 1.00 58.91
ATOM 16 O6 GUA A 1 13.135 43.683 125.607 1.00 58.91
ATOM 17 C5 GUA A 1 11.350 44.818 126.728 1.00 58.91
ATOM 18 N7 GUA A 1 10.447 45.200 125.746 1.00 58.91
ATOM 19 C8 GUA A 1 9.496 45.810 126.400 1.00 58.91
ATOM 20 C2* GUA A 1 9.338 47.838 129.227 1.00 58.91
ATOM 21 O2* GUA A 1 8.990 48.036 130.582 1.00 58.91
ATOM 22 C3* GUA A 1 8.576 48.757 128.282 1.00 58.91
ATOM 23 O3* GUA A 1 8.414 50.063 128.828 1.00 58.91

History

#1 Updated by Erik Lindahl over 13 years ago

This is not a bug, but invalid HDB entries. A line like

2 3 H21 N2 C2 N1

Will add two hydrogens, in geometry type 3, with a base name of "H21", using the final three atoms for
reference. According to the PDB standard the actual hydrogen names will then be basename+1 and
basename+2.

Also available in: Atom PDF