Project

General

Profile

Bug #65

pdb2gmx(ver3.3) cannot link Fe(HEME) to NE2(HIS)

Added by Tomoshi Kameda over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
High
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi

I'm going to simulate a HEME-Protein complex using GROMACS 3.3, and try

pdb2gmx -f pdb1a6n.ent

and select
0: GROMOS96 43a1 force field

But, pdb2gmx cannot link FE to NE2.
pdb2gmx outputs

Opening library file /home/kameda/gromacs-3.3/share/top/specbond.dat
5 out of 5 lines of specbond.dat converted succesfully
Special Atom Distance matrix:
HEME152 HEME152
FE1204 CAB1226
HEME152 CAB1226 0.565
HEME152 CAC1234 0.569 0.800

?????

On trial, I type same command using version3.2.1, then output is

Opening library file /usr/local/share/gromacs/top/specbond.dat
5 out of 5 lines of specbond.dat converted succesfully
Special Atom Distance matrix:
HIS12 HIS24 HIS36 HIS48 HIS64 HIS64 HIS81
NE2109 NE2199 NE2311 NE2430 NE2577 NE2578 NE2697
HIS24 NE2199 1.250
HIS36 NE2311 2.726 1.886
HIS48 NE2430 3.627 2.393 2.106
HIS64 NE2577 2.764 1.756 1.685 1.412
HIS64 NE2578 2.698 1.666 1.546 1.376 0.151
HIS81 NE2697 2.219 2.576 3.044 4.059 2.682 2.694
HIS82 NE2707 2.294 2.194 2.241 3.274 1.902 1.905 0.931
HIS93 NE2797 2.824 2.010 1.628 1.927 0.622 0.653 2.312
HIS97 NE2833 3.213 2.349 1.977 1.830 0.689 0.789 2.620
HIS113 NE2973 2.044 1.304 1.082 2.451 2.139 1.994 3.153
HIS116 NE21007 1.571 1.352 1.669 3.117 2.612 2.481 2.958
HIS116 NE21008 1.389 1.285 1.790 3.192 2.630 2.505 2.849
HIS119 NE21044 1.015 0.267 1.997 2.650 1.994 1.904 2.543
HEME152 FE1337 2.722 1.843 1.539 1.764 0.440 0.449 2.388
HEME152 CAB1359 2.255 1.512 1.325 2.115 0.865 0.806 2.024
HEME152 CAC1367 2.930 1.969 1.108 1.581 0.740 0.656 2.769
HIS82 HIS93 HIS97 HIS113 HIS116 HIS116 HIS119
NE2707 NE2797 NE2833 NE2973 NE21007 NE21008 NE21044
HIS93 NE2797 1.448
HIS97 NE2833 1.794 0.468
HIS113 NE2973 2.576 2.261 2.646
HIS116 NE21007 2.583 2.666 3.095 0.748
HIS116 NE21008 2.524 2.681 3.113 0.893 0.190
HIS119 NE21044 2.235 2.203 2.564 1.318 1.217 1.121
HEME152 FE1337 1.545 0.214 0.555 2.115 2.541 2.558 2.048
HEME152 CAB1359 1.199 0.626 1.082 1.760 2.076 2.078 1.668
HEME152 CAC1367 1.878 0.650 0.887 1.881 2.421 2.480 2.169
HEME152 HEME152
FE1337 CAB1359
HEME152 CAB1359 0.565
HEME152 CAC1367 0.569 0.800
Linking HIS-93 NE2-797 and HEME-152 FE-1337...

and .top file shows the linkage, for example,

[atoms]
926 NR 93 HIS1 NE2 388 -0.58 14.0067 ; qtot 1
1521 FE 152 HEME FE 643 0.4 55.847 ; qtot 2.4
.......
[bonds]
.......
926 1521 2

The line '926 1521 2' does not exist in .top file made by GROMACS
3.3.

For your information, there are not difference between
/home/kameda/gromacs-3.3/share/top/specbond.dat
with
/usr/local/share/gromacs/top/specbond.dat.

Is it caused by Bug ??

specbond.c (8.11 KB) specbond.c specbond.c David van der Spoel, 04/16/2006 10:52 PM

History

#1 Updated by David van der Spoel over 13 years ago

Please upload the relevant pdb file so that we can try to reproduce the problem

#2 Updated by Tomoshi Kameda over 13 years ago

(In reply to comment #1)

Please upload the relevant pdb file so that we can try to reproduce the problem

OK, you can download this file from
http://www.rcsb.org/pdb/downloadFile.do?fileFormat=pdb&compression=NO&structureId=1A6N

#3 Updated by David van der Spoel over 13 years ago

Created an attachment (id=36)
specbond.c

Please try dropping this file in your src/kernel directory and recompile and
test.

#4 Updated by Tomoshi Kameda over 13 years ago

specbond.c

Please try dropping this file in your src/kernel directory and >recompile and test.

Hi, David

I recompile and try link bond from FE to NE.
I comfirm that this pdb2gmx works correctly.

I also try other proteins containg HEME,
pdb2gmx works well.
For example, in case of 1dwr,

##################################
Opening library file /home/kameda/gromacs-3.3test/share/top/specbond.dat
5 out of 5 lines of specbond.dat converted succesfully
Special Atom Distance matrix:
HISA24 HISB36 HISB48 HISB64 HISB81 HISB82 HISA93
NE2182 NE2278 NE2385 NE2513 NE2631 NE2641 NE2726
HISB36 NE2278 1.862
HISB48 NE2385 2.342 2.008
HISB64 NE2513 1.769 1.663 1.265
HISB81 NE2631 2.728 3.143 4.006 2.757
HISB82 NE2641 2.231 2.273 3.176 1.944 0.946
HISA93 NE2726 2.019 1.595 1.776 0.630 2.370 1.488
HISB97 NE2757 2.379 1.931 1.680 0.712 2.667 1.830 0.469
HISB113 NE2891 1.192 1.031 2.206 1.970 3.297 2.591 2.126
HISB116 NE2916 1.231 1.593 3.031 2.444 2.785 2.290 2.438
HISB119 NE2941 0.294 1.985 2.600 2.052 2.797 2.359 2.272
HEME153 FE1195 1.856 1.502 1.613 0.450 2.462 1.590 0.213
HEME153 CAB1217 1.546 1.326 2.008 0.884 2.088 1.211 0.610
HEME153 CAC1225 2.003 1.095 1.482 0.767 2.826 1.901 0.625
HISB97 HISB113 HISB116 HISB119 HEME153 HEME153
NE2757 NE2891 NE2916 NE2941 FE1195 CAB1217
HISB113 NE2891 2.496
HISB116 NE2916 2.885 0.981
HISB119 NE2941 2.649 1.214 1.091
HEME153 FE1195 0.560 1.968 2.330 2.116
HEME153 CAB1217 1.073 1.691 1.856 1.765 0.565
HEME153 CAC1225 0.848 1.773 2.275 2.241 0.552 0.811
Linking HISA-93 NE2-726 and HEME-153 FE-1195... ###################

Thanks David!

#5 Updated by David van der Spoel over 13 years ago

I fixed an unrelated bug in the ffG43a1-n.tdb file which would generate the
wrong charge group number for the Ca in the first residue. You can correct this
manually in the top file or get the latest tdb files from CVS.

Also available in: Atom PDF