Project

General

Profile

Bug #730

Mdrun segfaults

Added by Shun Sakuraba almost 9 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
mdrun
Target version:
-
Affected version - extra info:
4.5.4
Affected version:
Difficulty:
uncategorized
Close

Description

I've experienced a segfault with mdrun.

The crash is reproduced with both 4.5.4 release and git master, no matter whether single-threaded or multi-threaded, and whether single or double precision.
The cause of the crash seems to be unstable box size on NPT sampling. (see md.log).
Although this is due to blowing-up simulation, I guess it is better to stop rather than crash (to prevent silent degradation).

Way to reproduce:

grompp_d -c conf.g96
mdrun_d

Around 1300 steps the program crashes.

conf.g96 (4.01 MB) conf.g96 Shun Sakuraba, 04/03/2011 11:44 AM
topol.top (1.13 KB) topol.top Shun Sakuraba, 04/03/2011 11:44 AM
grompp.mdp (293 Bytes) grompp.mdp Shun Sakuraba, 04/03/2011 11:44 AM
md.log (15.5 KB) md.log Shun Sakuraba, 04/03/2011 11:44 AM

History

#1 Updated by Rossen Apostolov over 8 years ago

  • Target version deleted (git master)

#2 Updated by Rossen Apostolov almost 8 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF