Project

General

Profile

Feature #805

add new GPUs to the mdrun-gpu compatibility list

Added by Szilárd Páll about 8 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Normal
Category:
mdrun
Target version:
Difficulty:
uncategorized
Close

Description

Add the following cards to the compatibility list both in gmx_gpu_utils and on the website:

M2090, M2075, C2075
GTX 560 Ti, GTX 550 Ti, GTX 590, GTX 580, GTX 570, GTX 580M, GTX 570M, GTX 560M?, GTX 485, GTX 470, 460?

Also remove: S2070, S2050

History

#1 Updated by Szilárd Páll about 8 years ago

  • Target version changed from 4.5.5 to 4.5.6

#2 Updated by Rossen Apostolov over 7 years ago

  • Status changed from New to In Progress

The lists have been updated on the website but not in gmx_gpu_utils

#3 Updated by Szilárd Páll over 7 years ago

Well, they're outdated again. We could replace this compatibility check with something like an estimate for compute power, e.g. core clock * #SMs * cores/SM.

#4 Updated by Roland Schulz over 7 years ago

  • Priority changed from High to Normal

Changed from High to Normal because it isn't a regression or a critical bug.

#5 Updated by Mark Abraham almost 7 years ago

  • Target version changed from 4.5.6 to future

May as well leave this hanging, with OpenMM moving to contrib? Re-target if you're keen, though.

#6 Updated by Szilárd Páll almost 7 years ago

Mark Abraham wrote:

May as well leave this hanging, with OpenMM moving to contrib? Re-target if you're keen, though.

I have a better idea: I want to remove the fixed list of GPU models and simply rely on checking the GPU capability required by OpenMM. This should remove dozens of lines of code and add <10 lines.

#7 Updated by Mark Abraham over 6 years ago

I think this issue should now be rejected.

#8 Updated by Teemu Murtola almost 6 years ago

  • Status changed from In Progress to Rejected
  • Target version changed from future to 4.5.8

I don't think anyone is going to maintain the OpenMM-related stuff any more. Please reopen if you think otherwise.

Also available in: Atom PDF