Project

General

Profile

Bug #83

trjconv failing to read trajectory

Added by Erik Marklund over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I used trjconv to shorten a xtc-file in the following way:
trjconv -f ~/simulations/pme/lysoz/watersim/sol_0-20ns.xtc
-s ~/simulations/pme/lysoz/watersim/grompp_run.tpr
-o lysoz.xtc
-tu ps
-b 19000
-e 20000

I got this error mesage:

Selected 0: 'System'
Reading frame 0 time 0.000
-------------------------------------------------------
Program trjconv, VERSION 3.3
Source code file: /home/spoel/GROMACS/release-3-3-
patches/gmx/src/gmxlib/trxio.c, line: 635

Fatal error:
Specified frame doesn't exist or file not seekable
-------------------------------------------------------

Removing the -tu flag didn't help.

If I did the shortening in two steps however, everything worked just fine:
trjconv -f ~/simulations/pme/lysoz/watersim/sol_0-20ns.xtc
-s ~/simulations/pme/lysoz/watersim/grompp_run.tpr
-o lysoz.xtc
-tu ps
-b 17000
-e 20000

trjconv -f lysoz.xtc
-s ~/simulations/pme/lysoz/watersim/grompp_run.tpr
-o lysoz_.xtc
-tu ps
-b 19000
-e 2000

History

#1 Updated by Erik Marklund over 13 years ago

(In reply to comment #0)

I used trjconv to shorten a xtc-file in the following way:
trjconv -f ~/simulations/pme/lysoz/watersim/sol_0-20ns.xtc
-s ~/simulations/pme/lysoz/watersim/grompp_run.tpr
-o lysoz.xtc
-tu ps
-b 19000
-e 20000

I got this error mesage:

Selected 0: 'System'
Reading frame 0 time 0.000
-------------------------------------------------------
Program trjconv, VERSION 3.3
Source code file: /home/spoel/GROMACS/release-3-3-
patches/gmx/src/gmxlib/trxio.c, line: 635

Fatal error:
Specified frame doesn't exist or file not seekable
-------------------------------------------------------

Removing the -tu flag didn't help.

If I did the shortening in two steps however, everything worked just fine:
trjconv -f ~/simulations/pme/lysoz/watersim/sol_0-20ns.xtc
-s ~/simulations/pme/lysoz/watersim/grompp_run.tpr
-o lysoz.xtc
-tu ps
-b 17000
-e 20000

trjconv -f lysoz.xtc
-s ~/simulations/pme/lysoz/watersim/grompp_run.tpr
-o lysoz_.xtc
-tu ps
-b 19000
-e 2000

Sorry. The last line should read -e 20000

#2 Updated by Filipe Maia over 13 years ago

The bug was caused by a file offset variable having the type int instead of
gmx_off_t in xtc_get_next_frame_start(). I fixed the bug and commited the bug
to cvs.

Also available in: Atom PDF