Project

General

Profile

Bug #99

trjconv: broken molecules with -pbc whole; molecules out of box with -pbc com

Added by pim empty about 13 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When trying to put an amino acid in the center of the box with trjconv,
problems occur for moving the water inside this image box.

The -pbc whole function broke the molecules at the borders, and gave the same
configuration as -pbc inbox (diff of confs from both commands gives zero output)

The -pbc com worked better, but placed a single water molecule outside the box!

confout.gro (181 KB) confout.gro input file I used for trjconv, contains amino acid at some place in the box, that was to be centered by trjconv pim empty, 08/21/2006 12:26 PM
whole.gro (181 KB) whole.gro trjconv output with -pbc whole. Broken bonds at the edges of the box, which should NOT be the case. pim empty, 08/21/2006 12:29 PM
inbox.gro (181 KB) inbox.gro trjconv output with -pbc inbox. Broken bonds at the edges of the box, as expected for -pbc inbox pim empty, 08/21/2006 12:30 PM
com.gro (181 KB) com.gro trjconv output with -pbc com. One water ends up outside the box.Seems to happen only to the last (water) molecule! Perhaps a loop problem. pim empty, 08/21/2006 12:33 PM
topol.tpr (445 KB) topol.tpr tpr file used pim empty, 08/21/2006 12:33 PM

Related issues

Has duplicate GROMACS - Bug #79: trjconv -pbc whole still breaks moleculesClosed05/10/2006

History

#1 Updated by pim empty about 13 years ago

Created an attachment (id=57)
input file I used for trjconv, contains uncentered amino acid

#2 Updated by pim empty about 13 years ago

Created an attachment (id=58)
trjconv output with -pbc whole

command used to create:
gromacs-3.3/bin/trjconv -f confout.gro -o whole.gro -s topol.tpr -center rect
-pbc whole

centered on group 1, output on group 0

#3 Updated by pim empty about 13 years ago

Created an attachment (id=59)
trjconv output with -pbc inbox

created with
/gromacs-3.3/bin/trjconv -f confout.gro -o inbox.gro -s topol.tpr -center rect
-pbc inbox

centered on group 1
output on group 0

#4 Updated by pim empty about 13 years ago

Created an attachment (id=60)
trjconv output with -pbc com

created with: gromacs-3.3/bin/trjconv -f confout.gro -o com.gro -s topol.tpr
-center rect -pbc com

centering on 1, output on group 0

one water ends up outside box.

#5 Updated by pim empty about 13 years ago

Created an attachment (id=61)
tpr file used

#6 Updated by pim empty about 13 years ago

(From update of attachment 57)
no bugs here!

#7 Updated by pim empty about 13 years ago

(From update of attachment 59)
no bugs here

#8 Updated by pim empty about 13 years ago

(From update of attachment 58)
Bug is probably that -pbc whole does the same as -pbc inbox.

#9 Updated by pim empty about 13 years ago

(From update of attachment 60)
Unclear to me why this happens.

#10 Updated by David van der Spoel about 13 years ago

  • Bug 79 has been marked as a duplicate of this bug. ***

#11 Updated by Berk Hess about 13 years ago

I have fixed all problemsin 3.3 and CVS.

I have fixed the center problem by adding a -boxcenter option,
as in the development version.

The -pbc com_res forgot to put the last residue in the box.

I also found and fixed more problems.

-pbc com_mol made a mess of the system

com_res and com_mol put the center of geometry in the box,
I changed this to com

I have added rm_pbc for com_res and com_mol

I have reordered and renamed the -pbc options:
first mol, res and atom
the -pbc whole option now only does rm_pbc, no inbox.

com_res and com_mol only worked for -ur rect, fixed
this to work with tric and compact.

I think this is a big improvement to trjconv.
-pbc mol or res is what one would usually want.

Berk.

Also available in: Atom PDF